
Using Chart components 

Charts allow you to represent data visually to make it easy for users to see comparisons, patterns, and trends. 
Xcelsius includes the following types of charts.  

Area Chart 

 
A standard chart with vertical and horizontal axes. Each point along the horizontal axis represents a data point. The 
actual values for each data point are plotted against the vertical axis. For each series, colored areas are created by 
connecting the plotted points against the horizontal axis. Use this chart in models that emphasize a trend line, such 
as Stock Prices or Revenue History.  

Bar Chart and Column Chart 

 
A single- or multi-bar chart that shows and compares one or more items over a period of time or in a specific range 
of values. You could, for example, use a column chart in models that contain the quarterly headcount by region.  

Bubble Chart 

 
The bubble chart is one of the most powerful analytic tools available. It lets you compare a group or series of items 
based on three different parameters. It has an X-axis and Y-axis to represent the item location over the chart area, 
and a Z value to represent the item size.  

You could, for example, use this chart to represent the market composition with the X-axis representing the Return 
On Investment (ROI) by industry type, the Y-axis representing the Cash Flow, and the Z-axis representing the 
Market Value.  

Bullet charts 
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This chart component provides a method to display information in a condensed, less-distracting format and is 
available with either a vertical or horizontal orientation.  

The Bullet chart components have a single primary measure (for example, current year-to-date revenue) that is 
displayed as a vertical or horizontal bar. A marker indicates a target or performance goal and changing color hues 
behind the bar indicate qualitative ranges of performance (for example, poor, satisfactory, and good).  

Designers can configure the Bullet chart to display multiple series and can configure the scale, axis, and ticks 
separately for each series. For example, the chart can be configured to show revenue in thousands of dollars, profit 
in dollars, and order size as a count.  

Combination Chart 

 
A combination column and line chart ideal for displaying a range of values and a trend line for those values. You can 
use the combination chart in models examining stocks. A line series might show the historical stock price over the 
year, and a column chart might show the volume of trading for that stock.  

Line Chart  

 
A single- or multi-line chart is ideal for showing tendency over a period of time. Use this chart in models that 
emphasize a trend or a continuing sequence of data, such as Stock Prices or Revenue History.  

OHLC Chart and Candlestick Chart  

 
The open-high-low-close (OHLC) and candlestick charts are primarily used to display stock data. Each marker 
corresponds to the values, which are represented as lines attached to the marker on the OHLC chart and as colors 
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on the candlestick chart. The open value displays the opening price of the stock. The high value displays the highest 
price the stock achieved on that day. The low value displays the lowest price the of the stock on that day. The close 
value displays the closing price of the stock.  

Pie Chart  

 
A circular chart that represents the distribution or participation of each item (represented by a slice) of a certain total 
that is represented as the overall pie value. The pie chart is appropriate for models such as Revenue Contribution by 
Product. In that example, the overall pie size would represent the total revenue, and each slice would represent a 
different product.  

Radar Chart and Filled Radar Chart 

 
Radar charts have axes that radiate outwards from the center of the chart. These charts can have several axes. 
They are useful for plotting multi-dimensional sets of data. In the filled radar chart, the shape created by connecting 
the points along each axis is filled in with color. You could use the radar charts to compare aspects of stocks. One 
axis could display the price, another the volume, another the Price to Earnings ratio, and any other relevant data.  

Sparkline 

 
The Sparkline chart is based on the Sparkline chart created by Edward Tufte. It provides a method for displaying a 
one-dimensional series (or multiple series) of numeric data in a way that is dense, takes up a small space, and can 
be quickly interpreted.  

Designers can set key data points (start value, end value, low value, and high value) that are displayed as markers 
on the Sparkline chart. They can also define a normal range that is displayed as a colored background behind the 
chart.  

Stacked Area Chart 

 
This standard chart has vertical and horizontal axes. Each point along the horizontal axis represents a data point. 
The actual values for the data points are plotted against the vertical axis, with each series adding to the total value. 
You could use the stacked area chart to compare the revenue for multiple products as well as the combined revenue 
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of all the products and the contribution of each product to the combined revenue.  

Stacked Column Chart and Stacked Bar Chart 

 
Stacked bars compare one or more variables, with each series adding to the total value. This chart compares 
several variables over a period of time, for example, Marketing Cost and Administrative Cost. Each one of the cost 
components is presented in a different color and each bar represents a different time period. The total bar size 
represents the Total Cost.  

Tree Map 

 
This chart displays hierarchical data in a small area. Each data point is represented by a rectangle.The tree maps 
display two parameters, represented by size and color intensity and can be used to compare two sets of data.  

For example, a tree map could be used to represent the size and interest rate of loans. You can set the size of the 
rectangle as the loan amount; a large loan would be represented by a larger rectangle. The color of the rectangle 
would represent the interest rate; a higher interest rate would be represented by a brighter color value.  

 
Tip: To see an example of a model with a Tree Map component, click File > Samples and open the sample 
file Tree Map.  

Waterfall Chart 

 
A waterfall chart is commonly used to display how an initial value is affected by a series of sequential positive or 
negative values. The initial and final values are represented by full columns, while the intermediate values are 
represented by partial columns. The columns are color-coded to distinguish between positive and negative values.  

For example, a waterfall chart could be used to represent the inventory level of goods that your retail business sells. 
Purchases of additional inventory are represented by positive values, and sales from inventory are represented by 
negative values.  

XY Chart 
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This chart displays data that encompasses two dimensions. The XY chart shows each data point as a result of the 
intersection of X values and Y values. You can, for example, use the XY chart in models that compare ROI (on the X 
axis) against Market Value (on the Y axis) for a group of companies.  

In this section: 

 To set up a chart 

 Chart General properties 

 Chart Drilldown properties 

 Chart Behavior properties 

 Chart appearance properties 

 Chart alerts properties 

 Configuring drilldown behavior 

 Allowing users to adjust chart scales 
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Using Container components 

Containers group and display other components.  

Note: Container components are not available in Xcelsius Present.  

Container components can be nested within each other to create multi-layer models. To avoid decreasing the 
model's performance, use only one layer of nesting, for example, a parent Tab Set component on each tab with no 
container components within the child containers.  

Canvas 

 
The Canvas container component is similar to the Panel container component, but it does not have any art, for 
example, background, borders, heading bar, and so on.  

In design mode, the container is visible to allow the designer to work with the component, but when the model is run, 
the container is invisible so components in the container appear to be free floating. If the components in the Canvas 
container extend beyond the container borders, scrollbars are added.  

Panel Container 

 
The Panel Container component acts as a smaller canvas within the main canvas and can hold one or more 
components. Components in the panel container can be moved, added, changed or deleted. In the "Object Browser" 
panel, to see the list of components within a panel container, click the Plus icon next to the Panel Container name.  

Note: The Panel2 Container component has the same functionality as a Panel Container, but with a different 
look.  

To explore a sample model that includes a Tab Set component, click File > Samples and select Panel Container.  

Tab Set 

 
The Tab Set component acts as a smaller canvas within the main canvas and contains multiple tab views. Each view 
can contain one or more components, which can be linked to different data sets. To display a view, users click its 
corresponding tab.  

When you configure the Tab Set component, you can increase or decrease the number of tab views by selecting the 
Tab Set component, and then clicking the Plus or Minus icons above the row of tabs. When the model runs, the Plus 
and Minus icons are not visible.  

Note: The Tab Set component functions as a single grouping of tabs. You cannot create sub-groups of the 
tabs within the component.  

To see an example of a model with a Tab Set component, click File > Samples and open the sample file Tab Set.  

In this section: 

 To set up a container 
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 Container general properties 

 Container behavior properties 

 Container appearance properties 
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Using Selector components 

Selector components allow you to pick an item from many members or from a list and insert the selected item's row, 
position, value, label, and so on into another row or cell in the embedded spreadsheet. Other components can then 
retrieve that information to complete other tasks.  

 
Note: For information about the functionality of Selector components, on the component's "Properties" panel, 

click the Information icon ( ).  

Accordion Menu 

 
The Accordion Menu is a two-level menu that lets users first select a category and then select from items within that 
particular category.  

 
Note: This component is not available in Xcelsius Present.  

 
Tip: To see an example of a model with an Accordion Menu component, click File > Samples and open the 
sample file Accordion Menu.  

Check Box 

 
A standard user-interface component where users toggle between two states: checked and unchecked.  

Combo Box 

 
A standard user-interface component that drops down a vertical list of items when it is clicked. Users can then select 
an item from the list.  

Filter 

 
The Filter component looks at a range of cells with multiple fields of data and categorizes them by unique data 
entries. The Filter sifts through the data range and inserts data corresponding to the list selections.  

Tip: To see an example of a model with a Filter component, click File > Samples and open the sample file 
Filter.  

Fisheye Picture Menu 

 
With the Fisheye Picture Menu, users select from a set of pictures or icons. As the mouse is moved over each item 
in the menu, the item is magnified. The closer the mouse is to the center of the item, the more the item is magnified. 
This creates an effect similar to that of a fish-eye lens.  

Note: This component is not available in Xcelsius Present. 
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Icon 

 
The Icon can be used as a selector or display component. As a selector, it functions similar to the Check Box 
component. It can represent the actual value contained in one cell and be compared to its target value in another 
cell.  

The Icon component can also be set to change color depending on its value relative to the target value, which is an 
Alert. For more information about alerts, see Understanding Alerts.  

At the same time, you can use the Icon to activate and display other components. For more information about 
controlling component visibility, see Managing the Visibility of Components.  

Note: To configure the Icon component as a display-only component, click the Appearance view and 
deselect Show On/Off. User will not be able to select the icon.  

Label Based Menu 

 
The Label Based Menu component lets users select items from a vertical or horizontal grouping of buttons.  

List Box 

 
A standard user-interface component that lets users select items from a vertical list.  

List Builder 

 
The List Builder provides a way for users to build their own set of data at run-time. This data set can then be used to 
populate another component. The List Builder consists of a "Source" list containing all possible selections, a 
"Destination" list containing the selected items, and an Update button. Users move items between the "Source" and 
"Destination" lists in one of the following ways: 

 Double-clicking items in either the "Source" or "Destination" list to move the item to the other list.  
 Dragging items from one list to another.  
 Using the Add and Remove buttons.  

When the Update button is clicked, the items in the "Destination" list are inserted into the destination range to be 
used by other components. To change the order of items in the "Destination" list, drag an item up or down in the list.  

Note: This component is not available in Xcelsius Present.  

 
Tip: To see an example of a model with a List Builder component, click File > Samples and open the sample 
file List Builder.  
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List View 

 
The List View component has the same functionality as the Table component, but lets the user sort the columns 
and adjust the width of the columns in the exported SWF file.  

Play Selector 

 
The Play Selector component sequentially inserts one row or column from a defined range into the destination cells 
you selected. You can link the destination cells to a chart so the chart data changes each time the play selector 
inserts a new row or column. The Play Selector component can display a large amount of data with a movie effect, 
which lets users view the data without clicking each selection.  

Note: This component is not available in Xcelsius Present.  

Push Button 

 
The Push Button component inserts specific data each time it is clicked. It can be used to allow users to restore 
Single Value components to their default values without resetting the values for the entire model or to create a pop-
up window that appears when the button is pushed.  

You can configure the Push Button to set the values of one or multiple cells to specific values when users click the 
button. The values only change when the user clicks the button, so users have more control over when the data is 
copied to the destination cells.  

Radio Button 

 
The Radio Button component lets users select from a vertical or horizontal group of selections.  

Scorecard 
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The Scorecard component allows you to display visual alerts in a grid. At run-time, users can click column headings 
to sort the grid according to the column's data. This component is similar to a List View selector, but it includes 
options to enable and configure alerts in columns and to add headers that allow users to sort the columns at run-
time.  

Alert levels can be displayed with cell background colors, font colors, or alert icons with or without values.  

Sliding Picture Menu 

 
With the Sliding Picture Menu, users select from a set of icons or pictures. The users can use arrows to scroll 
through the icons or the menu can be configured to scroll through the icons as the user moves the mouse.  

Note: This component is not available in Xcelsius Present.  

 
Tip: To see an example of a model with a Sliding Picture Menu component, click File > Samples and open 
the sample file Sliding Picture Menu.  

Spreadsheet Table 

 
The Spreadsheet Table component is a what-you-see-is-what-you-get (WYSIWYG) representation of any group of 
cells from your spreadsheet.  

 
Note: The Spreadsheet Table component can be used as a display component as well as a selector 
component. As a display component, the spreadsheet table is a graphic representation of a range of cells in 

the spreadsheet. To use the spreadsheet table as a display component, click the Cell Selector icon ( ) 
beside Display Data and select a range of cells to display from the spreadsheet. On the Behavior view, click 
Deselect All. Users will not be able to select rows in the table. To use the spreadsheet table as a selector 
component, after setting the Display Data range, set the Insert Option to rows.  

Ticker 

 
The Ticker component displays horizontally scrolling text in your model. Scrolling stops when the user moves the 
mouse pointer over the labels.  

Toggle Button 
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A standard user-interface component that lets users toggle between two states: on and off.  

In this section: 

 To set up selectors 

 Selector general properties 

 Selector behavior properties 

 Selector appearance properties 

 Selector alerts properties 
 

  

Page 5 of 5Using Selector components

12/22/2011mk:@MSITStore:C:\Program%20Files%20(x86)\Business%20Objects\Xcelsius\assets\help\local...

12



Using the Single Value components 

Single Value components let you add user interactivity to your models. Single Value means that the component or 
each component marker is linked to a single cell in the spreadsheet. At runtime, users can view the output of each 
component or marker, or adjust a marker to change the value in the associated cell.  

Input vs. output 

Single Value components have been classified as both input and output components, which means that you can use 
any Single Value component as an input or output element in your model.  

What dictates whether a Single Value component is an input (which permits user interaction) or output, is the cell to 
which it is linked. If the cell contains a formula of any type, the component is interpreted as an output. If the cell does 
not contain a formula, it is represented as an input.  

For example, if you have a Gauge linked to a cell that does not contain a formula, you can modify the value by 
dragging the gauge needle, thereby modifying the cell value. If you have a Gauge linked to a cell that contains a 
formula, you cannot modify the value. The value is set by the formula in the cell.  

Note: You can control user interaction with Single Value components by setting the Enable Interaction 
option on the Behavior view for selectors.  

Dial 

 
An input component. A Dial represents a variable that can be modified to affect other components. For example, to 
represent the Price per Unit.  

Slider and Dual Slider 

 
An input component. A Slider represents a variable that can be modified to affect other components. For example, to 
represent the Price per Unit. The Dual Slider allows you to adjust both the minimum and maximum values.  

Progress Bar 

 
An output component. A Progress Bar represents a value that changes and fills the progress bar area depending on 
its value.  

Gauge 

 
An output when bound to a cell containing a formula, or an input when bound to a cell containing a value.  

As an output, a Gauge represents a value that changes and moves the needle. As an input, a Gauge represents a 
variable that can be modified to affect other components. Users can interact with the Gauge by dragging the needle 
to change the value.  

Note: A single gauge can be configured to show multiple markers linked to different cells in the spreadsheet.  

Value 

 
An output when bound to a cell containing a formula, or an input when bound to a cell containing a value.  

As an output, a Value represents a value that changes. As an input, a Value represents a variable that can be 
modified to affect other components. Users can interact with the Value by typing in a new value.  

Spinner 
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An input component. A Spinner represents a variable that can be modified to affect other components. Users can 
interact with the Spinner by clicking the up and down arrows or by typing a value into the component.  

Play Control 

 
An input component. Play Control is used to automatically increase the value of a cell in your spreadsheet. For 
example, link the play button to a cell that contains the headcount. What will happen if the headcount increases by 
one, two, three, or more? Play Control takes the initial headcount value and increases its value automatically in 
increments.  

In this section: 

 To set up Single Value components 

 Single Value component general properties 

 Single Value component behavior properties 

 Single Value component appearance properties 

 Single Value component alerts properties 
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Using Map components 

Map components create models with geographical representations that can display data by region.  

The Map components have two major characteristics: they display data for each region and each region can also act 
as a selector. By combining these two features, you can create a model where the data for each region appears 
when you pass the pointer over the region. At the same time, each region can insert a row of data that contains 
additional information. This row of data is displayed by other components, such as a chart or value component.  

How does it work? 

Xcelsius 2008 associates data with each region in the map by using region keys. Each region in the map has a 
default region key, and you can enter your own region keys. When a region on the map is selected, the component 
searches either the first column or first row of that range's key. The data in the row or column corresponding to the 
key is associated with the region.  

By default, the USA maps use postal abbreviations as region keys; the Europe map uses the ISO (or International 
Organization for Standardization) two-digit country codes as region keys. To use the map components with existing 

spreadsheets, you can edit the region keys associated with each region by clicking the Manual Edit icon ( ) to type 

the new keys, or by clicking the Cell Selector icon ( ) beside the Region Key box to select the row or column 
containing the new keys by editing the region names.  

 
Note: In the spreadsheet you must enter the region keys and data in adjacent cells for both Display Data and 
Source Data.  

 
Tip: Xcelsius 2008 provides a spreadsheet that lists the default region codes for each map component. The 
file is located in the following location: C:\Program Files\Business 
Objects\Xcelsius\assets\samples\User Guide Samples  

In this section: 

 To set up Map components 

 Map general properties 

 Map behavior properties 

 Map appearance properties 

 Map alerts properties 
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Using the Text components 

This category contains components for placing labels and typing text into your model.  

Text components let you customize your model. Not only can you insert static text to identify areas and elements of 
your model, but you can also link the text components to cells in the embedded spreadsheet that contain formulas 
that will dynamically change the text displayed in the model based on the formula result. In addition, formulas can 
contain html code to increase your formatting options.  

Xcelsius 2008 includes the following Text-based components:  

Input Text Area 

 
The Input Text Area lets users input multiple lines of text into the model.  

Label 

 
The Label component lets you add an unlimited amount of text to enhance your models. You can use the Label 
component to create titles, subtitles, explanations, help, and more. Label text cannot be changed by the user.  

Input Text 

 
The Input Text component lets users type text into the model.  

In this section: 

 To set up Text components 

 Text general properties 

 Text behavior properties 

 Text appearance properties 
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Using the Other components 

This category contains an assorted set of components that you can use to enhance your models. Xcelsius 2008 
includes the following Other components:  

Calendar 

 
The Calendar component is a selector that lets you incorporate date selection into your models.  

 
Note: This component is not available in Xcelsius Present.  

Local Scenario Buttons 

 
The Local Scenario Button lets users save and load runtime configurations of an Xcelsius 2008 model on their local 
machine. Once saved, these configurations or scenarios can be loaded again, even after closing the model. The 
user also has the option to set a saved scenario as the default scenario so it loads when the model opens. These 
scenarios are saved to the local machine, and will be unavailable if the model is opened on a different machine.  

Trend Icon 

 
The Trend Icon changes its pointing direction, depending on the value of the cell to which it is linked:  

 If the value is positive, the arrow points up.  

 If the value is zero, the symbol is neutral.  

 If the value is negative, the arrow points down.  

History 

 
The History component tracks and displays the history of changes in a selected cell. This allows you to easily see 
the effect of changes in worksheet data.  

 
Note: This component is not available in Xcelsius Present.  

Panel Set 

 
The Panel Set component is a series of framing options that enables you to easily navigate between files in a 
presentation. You can embed JPEG or SWF files into the frames of the Panel Set component and adjust a variety of 
formatting features to customize the look of the component in your model.  

 

Page 1 of 2Using the Other components

12/22/2011mk:@MSITStore:C:\Program%20Files%20(x86)\Business%20Objects\Xcelsius\assets\help\local...

17



Note: This component is not available in Xcelsius Present.  

Source Data 

 
The Source Data component has no visual interface. It allows you to push data into other cells simply by changing 
the value of the component's Selected Index.  

 
Note: This component is not available in Xcelsius Present.  

Trend Analyzer 

 
The Trend Analyzer combines data analysis and model. The component analyzes spreadsheet data and inserts data 
points for a trend line into the spreadsheet, which can then be added to your model. You can also configure this 
component to forecast based on historical values.  

 
Note: This component is not available in Xcelsius Present.  

Print Button 

 
The Print Button allows users to easily print the model while it is running. The user can click the Print button to print 
the SWF file. The Print button is part of the canvas and will be visible in the printout.  

Reset Button 

 
The Reset Button returns the model to its original state. Users can interact with the components, then click the 
button to clear their changes.  

Grid 

 
The Grid component is a dynamic table that represents a group of rows and columns of content. The Grid lets you 
show the data just as it is on any table, or perform data modification that can impact other components.  

The Grid component differs from the Spreadsheet and List View components in that rather than being a static 
representation of the data table, the user can click the cells of the Grid and type new values or drag the values 
higher/lower  

 
Note: This component is not available in Xcelsius Present.  

In this section: 

 Other component general properties 

 Other component behavior properties 

 Other component appearance properties 

 Other component alerts properties 

 To configure Trend Analyzer components 
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Using Art and Background components 

Art and background components provide visual enhancements for models. You can use them to enhance and 
customize your dashboards. The background components can also be used to import images or Flash movies into 
your models.  

Xcelsius 2008 includes the following Art and Background components:  

Background  

 
Backgrounds are prebuilt artwork that you can add to your models. You can use them to create visual divisions or 
groups of related components. Unlike Container components, backgrounds cannot contain or hold other 
components. They simply provide a visual background.  

Ellipse  

 
The Ellipse or Oval component allows you to create visual divisions or outlines to define or contain sections or 
components.  

Image Component 

 
Use this component to display JPEG images or SWF files. The Image component allows you to add your own logos 
or artwork to models. You can also import Flash files into this component to add videos, animations, and other 
interactive elements.  

Line 

 
The Vertical or Horizontal Line component allows you to create visual divisions or outlines to define or contain 
sections or components.  

Rectangle 

 
The rectangle component allows you to create visual divisions or outlines to define or contain sections or 
components.  

In this section: 

 To configure Background components 

 To configure Image components 

 To configure Ellipse or Rectangle components 

 To configure Line components 
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Using the Web Connectivity components 

This category contains a group of components that provides options for linking your models to the Web.  

Note: In Xcelsius Engage and Xcelsius Enterprise, web connectivity is built in. In addition to using these 
components, you can use the "Data Manager" to configure web connectivity options. For more information, 
see Managing data connections.  

Connection Refresh Button 

 
A button that manually refreshes the connection it is linked to.  

Note: This component is not available in Xcelsius Present.  

 
Tip: To see an example of a model with a Refresh Button, click File > Samples and open the sample file 
Connection Refresh.  

Reporting Services Button 

 
The Reporting Services Button component enables you to connect to the XRS server and select a report to use to 
populate the model.  

Note: This component is available only in Xcelsius Engage Server and BusinessObjects Xcelsius Enterprise.  

Slide Show 

 
The Slide Show component creates a slide show of URL-based images and SWF files.  

 
Note: This component is not available in Xcelsius Present.  

Unlike the normal Image Component, which requires that you first Import the file, the Slide Show component loads 
the image from the URL specified in the URL data source. If the Slide Show URL changes, the Slide Show 
component attempts to load the image from the new location. Once the image is loaded , the component transitions 
from the current image to the one specified at the new URL data source.  

Note: When an image is imported into normal Image components, Xcelsius stores its own local copy of the 
file internally in the XLF file. The original file is no longer accessed or used in the model. Because the file data 
is stored within the XLF, the XLF can be moved or emailed and the contents of the file travels with it. 
However, the Slide Show points to a URL, which can change at runtime. Since the image is not built into the 
XLF, the Slide Show component must be able to access the URL and the image must be available to load at 
runtime.  

 
Caution: If a model is connected to an external data source, when the model runs, Adobe security restrictions 
apply. When the model is run locally, the SWF file or the host application file must be made trusted. If the file 
is run on a web server, there must be a cross-domain policy file. For more information, see Adobe Flash 
Player Security Restrictions.  

SWF Loader 

 
Note:  

 This component is not available in Xcelsius Present.  
 The Adobe Flash Player memory management method controls when inactive items are removed from memory. 

To avoid heavy memory consumption when using the SWF Loader: 

 Reduce the number of SWF Loader and Slide Show components included in a single model  
 Reduce the number of SWF files that the SWF Loader and Slide Show components in the model must load 
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concurrently at run-time.  

The SWF Loader component is similar to the Slide Show component; it loads SWF files from a specified URL and 
avoids the need to first import the files. The SWF Loader has better memory management than the Slide Show 
component, but it doesn't have transition effects and cannot block mouse events.  

Loaded SWFs are not built into the XLF, so the SWF Loader component must be able to access the URL and the file 
must be available to load at runtime.  

Caution: If a model is connected to an external data source, when the model runs, Adobe security restrictions 
apply. When the model is run locally, the SWF file or the host application file must be made trusted. If the file 
is run on a web server, there must be a cross-domain policy file. For more information, see Adobe Flash 
Player Security Restrictions.  

URL Link Button 

 
A button that links to a relative or absolute URL when pressed.  

In this section: 

 To set up Web Connectivity components 

 Web connectivity general properties 

 Web Connectivity behavior properties 

 Web Connectivity appearance properties 
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Deleting components  

Delete any selected components by pressing DELETE or selecting Delete from the right-click context menu.  

 
Tip: You do not need to ungroup components to delete components that are in the group.  

Deleting a component can be undone pressing CTRL+Z or clicking Undo on the Edit menu.  
 

  

Page 1 of 1Deleting components

12/22/2011mk:@MSITStore:C:\Program%20Files%20(x86)\Business%20Objects\Xcelsius\assets\help\local...

22



Understanding Alerts 

Alerts call the attention of the user to a specific item or action that has reached a pre-established limit. These limits, 
often called targets, budgets, benchmarks, and so on, are a standard to which an item is compared.  

In Xcelsius 2008, you can define alerts on most charts and single-value components. When alerts are enabled, the 
component represents the current alert level as a color. Typically, green represents a desired condition, yellow 
indicates that the situation is not ideal, and red marks an issue as critical. When you define the alert, you specify 
which values to monitor, as well as, the alert thresholds and whether it is preferable for the values to be higher than, 
lower than, or as close to the target value as possible. You can also define custom colors.  

Alerts are available on the following components: 

In this section: 

 To configure alerts 

Related Topics: 

 Using Chart components 

 Using the Single Value components 

 Using Selector components 

 Using the Other components 
 

Component 
Type 

Component 

Charts 

Bar, Bubble, Column, Combo, Line, Radar, Stacked Bar, Stacked Column, XY  

Note: Alerts are unavailable for charts with multiple data series, except for 
combination charts.  

Selectors 
Combo Box, Icon, Label Based Menu, List Box, List Builder, Scorecard, Spreadsheet 
Table, Ticker  

Single Value 
Dial, Dual slider, Gauge, Horizontal Progress Bar, Horizontal Slider, Spinner, Value, 
Vertical Progress Bar, Vertical Slider 

Maps All 
Other Grid 
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To configure alerts 

If you want a component to indicate when its data value reaches a specific range, you can configure and customize 
alerts.  

1. Select the component and open the "Properties" panel.  

2. On the "Properties" panel, click the Alerts view.  

3. Select the Enable Alerts check box. 

 
Note: For Scorecard components, you can enable alerts for different columns individually. For each 
column that you want to show alerts for, select the checkbox in the Show column and then define the 
alert properties for the selected column.  

For Label-Based Menu, List Builder, List Box, and Combo Box components, in the Alert Values box, specify 
the values to be compared to the target values for alerts. Type a value or click the Cell Selector icon and 
select a source location in the spreadsheet.  

4. Select one of the following methods to use for the alerts: 

5. Under Alert Thresholds, set the following options: 

6. To automatically define the colors assigned to each threshold level, select the Enable Auto Colors 
checkbox. 

 
Note: To manually assign colors to each threshold level, deselect this option and select the Color 
Selector icon beside each threshold level to set its color.  

7. If Enable Auto Colors is selected, to set a different color gradient scheme, click the Auto-color icon ( ). 

The Color dialog box opens.  

8. On the Color dialog box, select a color scheme from the "Custom" or "Built-in" lists, or, to create a new color 
gradient, click Create new gradient and set the following options: 

Option Description 
As a Percent of 
Max Value  

For Single Value components only. Select this option to base alerts on specified 
percentages of the value set on the General view for the scale Maximum Limit.  

As Percentage of 
Target  

Select this option to base the alerts on percentages of specified target values. 

To set the target values by linking to cells in the embedded spreadsheet, click the Cell 

Selector icon. To manual define the target values, click the Manual Edit icon ( ).  

Note: You can set separate target values for each data point.  

By Value  Select this option to base the alerts on values you set in the "Alert Thresholds" area.  

Option Description 
Use a 
Range  

Select this option to select the threshold levels from cells in the embedded spreadsheet, then 
click the Cell Selector icon to select the cells.  

Enter a 
Value  

To manually define the threshold values, do the following: 

To Do this 
Edit existing 
values  

Click the value in the From or To column and type a new 
value  

Add a value to 
the list  

Type it in the box and click Add.  

Delete a level  Click the Delete icon beside the value.  

Assign colors 
to threshold 
levels 

Click the Color Selector icon beside each level to set the 
color. For more information about using the color 
selector, see Setting colors for component elements.  

Note: If the Enable Auto Colors checkbox is 
selected, you cannot set colors for each threshold 
individually.  

Option Description 

2-Color Select this option to include 2 colors on the alert scale. 

Page 1 of 2To configure alerts

12/22/2011mk:@MSITStore:C:\Program%20Files%20(x86)\Business%20Objects\Xcelsius\assets\help\local...

24



9. To set the color order, select one of the following options: 
 Low Values are Good - Use this option when the ideal value type is lower than the target value. For 

example, to represent expenses when you want them to be as low as possible.  
 Middle Values are Good - Use this option when the ideal value type is as close as possible to the 

target value. For example, to represent inventory when you want inventory quantities to be as 
accurate as possible.  

Note: This option is only available when using percentages.  

 High Values are Good - Use this option when the ideal value type is higher than the target value. For 
example, to represent revenue when you want revenue values to be as high as possible.  

10. For Vertical Slider, Horizontal Slider, Horizontal Progress Bar, Dial, Dual Slider, and Gauge components, 
select where you want the alert color to appear: 

Alerts are configured for the component.  
 

Gradient 
3-Color 
Gradient 

Select this option to Include 3 colors on the alert scale. 

Colors 
For each color on the scale and for a "no data" color, set the color to use for the fill and the 
text. Click the down arrow beside each color to open the Color dialog box.  

Option Description 
Background The component background displays the alert color. 
Marker The marker, needle, and so on displays the alert color. 
Value A text box beside the component contains the current value and displays the alert color. 
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Managing the Visibility of Components 

When models contain too much information or too many visual components, users may have difficulty focusing on 
specific sets of information. If you need to display a lot of information, you can simplify the visual layout by displaying 
some information only when it is needed. To make your model easy to navigate you may want to re-use certain 
areas of the canvas and hide and show components at runtime.  

Dynamic visibility allows you to control when components are visible based on the contents of a spreadsheet cell. 
Put simply, a component using dynamic visibility is visible when the status matches the key, otherwise the 
component is hidden. For example, you can add a Toggle Button to display a specific chart. The Toggle Button is 
configured to alternately insert showChart and hideChart into a Destination cell each time it is clicked. By linking 
the Chart's status to this Destination cell and setting the Chart's Key to showChart, the Chart becomes visible when 
the Toggle Button inserts the value showChart and hidden when the Toggle Button inserts hideChart.  

In a more complex model, you may want to switch between several different components. To accomplish this, use 
the Key and a Selector. For example, a model might need to switch between different charts. You can assign each 
chart a unique Key, such as chart1, chart2, and so on. Then, add a List Box component to the canvas and set 
the source data to match the chart keys and the destination as a blank cell in the spreadsheet. When you link each 
chart's Status to the destination cells, each time a selection is made on the List Box and the chart's key is inserted 
into the destination cell, the chart is visible and the others are hidden.  

When dynamic visibility is enabled, you can also add animation effects to how the component appears and 
disappears from the model.  

Tip: To see an example of a model with dynamic visibility, click File > Samples and open the sample file 
Dynamic Visibility.  

 
Note: Add-on components do not support dynamic visibility. If you want to control the visibility of Add-on 
components, you can place the component in a Canvas container and apply the dynamic visibility settings to 
the Canvas container to show or hide the Add-on component it contains.  

In this section: 

 To set up Dynamic Visibility 

 To configure entry effects for dynamic visibility 

Related Topics: 

 Chart Behavior properties 

 Container behavior properties 

 Selector behavior properties 

 Single Value component behavior properties 

 Map behavior properties 

 Text behavior properties 

 Other component behavior properties 
 

  

Page 1 of 1Managing the Visibility of Components

12/22/2011mk:@MSITStore:C:\Program%20Files%20(x86)\Business%20Objects\Xcelsius\assets\help\local...

26



To set up Dynamic Visibility 

A model containing a component is open on the canvas.  

1. Select the component and open the "Properties" panel.  

2. On the "Properties" panel, click Behavior > Common.  

3. In the "Dynamic Visibility" area, beside the Status box, click the Cell Selector icon ( ) and select a cell in 
the spreadsheet that will control the component's visibility. 

 
Note: Do not select cells that are already bound to this component, for example, its data ranges, or 
those data sources will not refresh when dynamically changed.  

4. In the Key box, type a value or click the Cell Selector icon ( ) and select a cell that will contain the key 
value for this component. 

 
Note: The Key box is not available unless Status has been set.  

When the value in the Status cell matches the key value, the component will be visible.  

5. Place a component on the canvas that you will configure to enter values into the Status cell set in step 3. 
Open the "Properties" panel. 

Typically, this will be a Selector component, such as a Checkbox component or a Radio Button component, 
but could also be a chart or a map component that is configured to insert data into the specified cells.  

6. On the "Properties" panel, on the General tab, in the Source Data box, enter or select the key values for the 
components it is controlling. 

 
Note: If the selector is controlling only one component, you need to enter a key value for hiding the 
component as well.  

7. In the Destination box, click the Cell Selector icon ( ) and select the cells selected for the Status box in 
step 3.  

At runtime, when the user clicks the selector component, it inserts a key value into the Status cell. The dynamically 
visible component is visible when the inserted value matches its key value.  

If desired, you can configure the component's entry effect to specify how the component appears and disappears 
from the model.  

Related Topics: 

 Managing the Visibility of Components 

 To configure entry effects for dynamic visibility 
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Disabling User Input 

Many components can be configured to allow users to modify values at runtime. If you do not want users to change 
data values from the model, for many components, you can adjust their configuration to prevent interaction. 
However, if the design requires that the component accept user input, you can use a Background component to 
block input.  

 
Note: For Single Value components, you can also prevent users from changing data values in two ways: 
bind the component to a cell that contains a formula or deselect the Enable Interaction option on the 
Behavior > Common menu of the "Properties" panel.  

In this section: 

 To configure Background components to block user input 

Related Topics: 

 Single Value component behavior properties 
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